What’s Vulnerable › Vulnerabilities
CVE-2026-69251: Flowise RCE via TypeORM DataSource
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-04 · updated 2026-09-14
- Weakness: CWE-94
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, Flowise record manager and agent memory nodes allowed users to set arbitrary TypeORM DataSource options through the additionalConfig input in packages/components/nodes/recordmanager/MySQLRecordManager/MySQLrecordManager.ts, packages/components/nodes/recordmanager/PostgresRecordManager/PostgresRecordManager.ts, packages/components/nodes/recordmanager/SQLiteRecordManager/SQLiteRecordManager.ts, packages/components/nodes/memory/AgentMemory/MySQLAgentMemory/MySQLAgentMemory.ts, and packages/components/nodes/memory/AgentMemory/AgentMemory.ts. TypeORM DataSource options such as entities, subscribers, and migrations can load local JavaScript files, allowing an authenticated user to execute arbitrary code on the server by uploading a JavaScript payload and referencing it from additionalConfig.entities. This issue is fixed in version 3.1.3.
Affected products
- FlowiseAI Flowise: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-g32j-mmxr-gfq5
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-g32j-mmxr-gfq5
Get alerted when CVE-2026-69251 or the next vulnerability affects your stack