What’s Vulnerable › Vulnerabilities
CVE-2026-6951
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-25 · updated 2026-07-15
- Weakness: CWE-94
Description
Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.
Affected products
- simple-git: from 3.15.0 before 3.36.0 — fixed in 3.36.0
How to fix
Upgrade to a fixed version: simple-git 3.36.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/KKC73/02d1d97f3410756095b501fda0ac8ca6
- https://github.com/steveukx/git-js/commit/89a2294febed5dfe737c4c735d936bb6018746a8
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-16300211
- https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-15456078
- https://access.redhat.com/security/cve/CVE-2026-6951
- https://bugzilla.redhat.com/show_bug.cgi?id=2461750
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-6951.json
- https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-15456078
Get alerted when CVE-2026-6951 or the next vulnerability affects your stack