What’s Vulnerable › Vulnerabilities
CVE-2026-6970: authd Denial of Service and Local Privilege Escalation
- Severity: high (CVSS 7.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-27 · updated 2026-10-26
- Weakness: CWE-842
Description
authd prior to version 0.6.4 contains a logic error in primary group ID assignment that can lead to local privilege escalation. When a user's primary group ID (GID) differs from their UID, either because the account was created with authd prior to version 0.5.4 or because the primary group was manually changed via the `authctl group set-gid` command, and the user's identity provider record is updated, authd incorrectly resets the user's primary group ID to their UID upon next login. This causes newly created files and directories to be owned by the wrong group, causing denial of service issues, and potentially granting unintended access to other local users and allowing local privilege escalation.
Affected products
- Canonical authd: from 0.6.0 before 0.6.4; from 0.6.1 before 0.6.1ubuntu0.1 — fixed in 0.6.1ubuntu0.1, 0.6.4
How to fix
Upgrade to a fixed version: Canonical authd 0.6.1ubuntu0.1, 0.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/authd/commit/154b428305cb1a7a19c897626fefd09d6dde8b9f
- https://github.com/canonical/authd/security/advisories/GHSA-fg3j-5w9g-hmg7
Get alerted when CVE-2026-6970 or the next vulnerability affects your stack