What’s Vulnerable › Vulnerabilities
CVE-2026-7040: Text::Minify::XS versions from 0.3.0 before 0.7.8 for Perl have heap overflow when processing some malformed UTF-8 characters
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-27 · updated 2026-10-26
- Weakness: CWE-122
Description
Text::Minify::XS versions from 0.3.0 before 0.7.8 for Perl have a heap overflow when processing some malformed UTF-8 characters. The minify functions mishandled some malformed UTF-8 characters, leading to heap corruption. Note that the minify_utf8 function is an alias for minify.
Affected products
- RRWO Text::Minify::Xs: from 0.3.0 before 0.7.8 — fixed in 0.7.8
How to fix
Upgrade to a fixed version: RRWO Text::Minify::Xs 0.7.8. Check the vendor advisory for mitigations.
References
- https://github.com/robrwo/Text-Minify-XS/security/advisories/GHSA-jqhf-vv4h-77h2
- https://metacpan.org/release/RRWO/Text-Minify-XS-v0.7.8/changes
- http://www.openwall.com/lists/oss-security/2026/04/27/5
Get alerted when CVE-2026-7040 or the next vulnerability affects your stack