What’s Vulnerable › Vulnerabilities
CVE-2026-70472: Flowise: Cross-workspace credential IDOR in openai-assistants-vector-store
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-04 · updated 2026-10-24
- Weakness: CWE-285
Description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, Flowise openai-assistants-vector-store endpoints accept a client-controlled credential parameter and load credentials by id without checking whether that credential belongs to the caller workspace. Route permissions assistants:* only check feature access. The controller passes req.query.credential straight to the service, and the service uses findOneBy({ id: credentialId }), decrypts the credential, and calls OpenAI APIs without a workspaceId check. If an attacker knows another workspace credentialId, the attacker can use that workspace OpenAI key, read, modify, or delete victim vector stores and files, cause billing impact on the victim OpenAI account, and violate multi-tenant boundaries. This issue is fixed in version 3.1.3.
Affected products
- FlowiseAI Flowise: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/commit/d81483b70c997ddf981acc9c49fbd9a02fa345cd
- https://github.com/FlowiseAI/Flowise/pull/6170
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise@3.1.3
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-chm3-vqcf-52rx
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-chm3-vqcf-52rx
Get alerted when CVE-2026-70472 or the next vulnerability affects your stack