What’s Vulnerable › Vulnerabilities
CVE-2026-70626: NLTK before 3.9.4 Symlink Escape via CorpusReader
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-22 · updated 2026-10-14
- Weakness: CWE-59
Description
NLTK versions before 3.9.4 contain a symlink escape vulnerability in CorpusReader.open() that allows local attackers to read arbitrary files outside the corpus root. The vulnerability exists because path validation is lexical and does not account for symlink resolution, enabling attackers to place symlinks inside the corpus root to access files outside the intended boundary.
Affected products
- nltk: before 3.9.4 — fixed in 3.9.4
How to fix
Upgrade to a fixed version: nltk 3.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/nltk/nltk/security/advisories/GHSA-r6gq-whwq-mvg9
- https://www.vulncheck.com/advisories/nltk-before-symlink-escape-via-corpusreader
- https://github.com/nltk/nltk/security/advisories/GHSA-r6gq-whwq-mvg9
Get alerted when CVE-2026-70626 or the next vulnerability affects your stack