What’s Vulnerable › Vulnerabilities
CVE-2026-70652: libvips: Possible heap-based buffer read overflow when resizing and re-encoding a JPEG with gain map
- Severity: low (CVSS 2.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-10-26
- Weakness: CWE-126
Description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built with libultrahdr support can incorrectly size an output buffer in libvips/foreign/uhdrsave.c within vips_foreign_save_uhdr_set_raw_hdr when a pipeline enlarges an incoming JPEG to a very large output before encoding a gain map through VipsForeignSaveUhdr. The undersized allocation can cause a heap buffer over-read that may disclose adjacent data or crash the process. This issue is fixed in version 8.18.3.
Affected products
- libvips: before 8.18.3
References
- https://github.com/libvips/libvips/commit/cff17794f0698a4f47c74bb31c9700b2c83252a8
- https://github.com/libvips/libvips/pull/5039
- https://github.com/libvips/libvips/releases/tag/v8.18.3
- https://github.com/libvips/libvips/security/advisories/GHSA-h27h-jf9v-m8rg
Get alerted when CVE-2026-70652 or the next vulnerability affects your stack