What’s Vulnerable › Vulnerabilities
CVE-2026-70653: libvips: Possible heap-based buffer read overflow when decoding a well-crafted RLE Radiance image
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-10-26
- Weakness: CWE-122
Description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, the old-style Radiance RLE decoder in libvips/foreign/radiance.c can process a repeat marker at the beginning of a scanline in scanline_read_old and read q[-1] before any prior pixel exists. A crafted Radiance image loaded through VipsForeignLoadRad can therefore disclose four bytes of adjacent heap data, most likely other image data. This issue is fixed in version 8.18.3.
Affected products
- libvips: before 8.18.3
References
- https://github.com/libvips/libvips/commit/dc945573e15d598054e701c65b90a35b16b19304
- https://github.com/libvips/libvips/pull/5037
- https://github.com/libvips/libvips/releases/tag/v8.18.3
- https://github.com/libvips/libvips/security/advisories/GHSA-fh99-55jf-5hj3
Get alerted when CVE-2026-70653 or the next vulnerability affects your stack