What’s Vulnerable › Vulnerabilities
CVE-2026-70654: libvips: A well-crafted PPM image processed via a custom source could lead to possible heap buffer write overflow
- Severity: medium (CVSS 5.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-10-26
- Weakness: CWE-122
Description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.
Affected products
- libvips: before 8.18.3
References
- https://github.com/libvips/libvips/commit/80e021c6cdda0f80b756c2109d99839c94c03258
- https://github.com/libvips/libvips/pull/5038
- https://github.com/libvips/libvips/releases/tag/v8.18.3
- https://github.com/libvips/libvips/security/advisories/GHSA-rjmm-3qch-m9rg
Get alerted when CVE-2026-70654 or the next vulnerability affects your stack