What’s Vulnerable › Vulnerabilities
CVE-2026-71253: Apache Johnzon: ClassConverter loads & static-initializes an attacker-named class from untrusted JSON
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-20
- Weakness: CWE-470
Description
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Johnzon. ClassConverter loads & static-initializes an attacker-named class from untrusted JSON. This issue affects Apache Johnzon: from 1.0.0 before 2.2.0. Users are recommended to upgrade to version 1.3.1 (javax namespace) or 2.2.0 (jakarta specification namespace), which fixes the issue.
Affected products
- Apache Software Foundation Apache Johnzon: from 2.0.0 before 2.2.0; from 1.0.0 before 1.3.1 — fixed in 1.3.1, 2.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Johnzon 1.3.1, 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/johnzon/commit/91e7b0d21d08d138944e2570691939739422a3d6
- https://github.com/apache/johnzon/commit/dd3d00634c746a2173a2518e882e85e8a151bf30
- https://lists.apache.org/thread.html/3vgm1yo2sn9yhkvvs9lc4ro01vl3zt68
Get alerted when CVE-2026-71253 or the next vulnerability affects your stack