What’s Vulnerable › Vulnerabilities
CVE-2026-71486: vLLM: Derender endpoints decode caller-supplied GenerateResponse token IDs without output bounds
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-17 · updated 2026-10-23
- Weakness: CWE-400
Description
vLLM is an inference and serving engine for large language models. Prior to 0.26.0, the /v1/completions/derender and /v1/chat/completions/derender endpoints accept caller-supplied GenerateResponse objects whose generate_responses, choices, token_ids, prompt_logprobs, logprobs.content, top_logprobs, and routed_experts structures are processed by OnlineDerenderer and tokenizer.decode before max_model_len, max_tokens, max_num_seqs, or response-size limits are enforced, allowing an authenticated API client to consume excessive CPU and memory and produce oversized responses. This issue is fixed in version 0.26.0.
Affected products
- vllm-project vllm: before 0.26.0 — fixed in 0.26.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.26.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/8e61b646e2d157f9b93451fa048f9c8530c8a67b
- https://github.com/vllm-project/vllm/pull/47260
- https://github.com/vllm-project/vllm/releases/tag/v0.26.0
- https://github.com/vllm-project/vllm/security/advisories/GHSA-8737-qx52-hjff
Get alerted when CVE-2026-71486 or the next vulnerability affects your stack