What’s Vulnerable › Vulnerabilities
CVE-2026-71506: Dolibarr < 24.0.0 Payments REST API Improper Authorization via Delete Endpoint
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-12
- Weakness: CWE-863
Description
Dolibarr before 24.0.0 contains an improper authorization vulnerability in the payments REST API delete endpoint that allows authenticated attackers with invoice-deletion rights to permanently delete any payment record by bypassing the intended payment-issuance rights check. Attackers can exploit this misconfigured permission check to zero paid amounts on invoices and remove entries from accounting exports, causing financial data integrity loss.
Affected products
- dolibarr: before 24.0.0 — fixed in 24.0.0
How to fix
Upgrade to a fixed version: dolibarr 24.0.0. Check the vendor advisory for mitigations.
References
- https://codeant.ai/security-research/cve-2026-71506-dolibarr-payment-deletion-via-incorrect-authorization
- https://github.com/Dolibarr/dolibarr/commit/e01a12ffea4675f5bcc1c886f06ec6a29d5e4801
- https://github.com/Dolibarr/dolibarr/releases/tag/24.0.0
- https://www.vulncheck.com/advisories/dolibarr-payments-rest-api-improper-authorization-via-delete-endpoint
Get alerted when CVE-2026-71506 or the next vulnerability affects your stack