What’s Vulnerable › Vulnerabilities
CVE-2026-71508: Dolibarr < 24.0.0 REST API Improper Authorization via User Update Endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-12
- Weakness: CWE-862
Description
Dolibarr before 24.0.0 contains an improper authorization vulnerability in the user REST API update endpoint that allows attackers with user-write rights to modify payroll fields by exploiting an incomplete credential denylist that omits payroll columns. Attackers can rewrite salary, bonus, hourly rate, daily rate, and weekly hours for any user without holding payroll rights, with the modified values appearing in payroll export reports.
Affected products
- dolibarr: before 24.0.0 — fixed in 24.0.0
How to fix
Upgrade to a fixed version: dolibarr 24.0.0. Check the vendor advisory for mitigations.
References
- https://codeant.ai/security-research/cve-2026-71508-dolibarr-payroll-mass-assignment
- https://github.com/Dolibarr/dolibarr/commit/c85d0e840725a3c1a2f49b3e97766469c3cb02b6
- https://github.com/Dolibarr/dolibarr/releases/tag/24.0.0
- https://www.vulncheck.com/advisories/dolibarr-rest-api-improper-authorization-via-user-update-endpoint
Get alerted when CVE-2026-71508 or the next vulnerability affects your stack