What’s Vulnerable › Vulnerabilities
CVE-2026-71537: Paymenter: Credit-refund double-spend race condition in service downgrade (doUpgrade)
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-24
- Weakness: CWE-362
Description
Paymenter is a free and open-source webshop solution for management of hosting services. Prior to 1.5.7, app/Livewire/Services/Upgrade.php::doUpgrade() relies on Service::upgradable to check for a pending service upgrade and later executes $credit->increment('amount', abs($price)) without DB::transaction or lockForUpdate() spanning those operations. An authenticated customer with an active downgradable service can submit concurrent downgrade requests that each observe no pending upgrade, create separate upgrade records, and increment the same account credit balance, producing multiple spendable refunds for one downgrade. This issue is fixed in version 1.5.7.
Affected products
- Paymenter: before 1.5.7
References
- https://github.com/Paymenter/Paymenter/commit/a42e7f8bafce054ad70de3a2c2ac94d13579f41b
- https://github.com/Paymenter/Paymenter/releases/tag/v1.5.7
- https://github.com/Paymenter/Paymenter/security/advisories/GHSA-5gmm-hjfj-8ff7
Get alerted when CVE-2026-71537 or the next vulnerability affects your stack