What’s Vulnerable › Vulnerabilities
CVE-2026-71558: Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-10-24
- Weakness: CWE-502
Description
Heap type confusion vulnerability in Apache Fory C++ deserialization. This issue affects Apache Fory C++ versions from 0.14.0 before 1.5.0. A crafted input payload can bypass type compatibility checks during polymorphic smart-pointer deserialization, causing an object of an incompatible type to be treated as the declared base type. This may result in undefined behavior and potentially lead to denial of service or arbitrary code execution. Users are recommended to upgrade to Apache Fory 1.5.0, which fixes this issue. Applications not using Apache Fory C++ polymorphic smart-pointer deserialization are not affected.
Affected products
- Apache Software Foundation Apache Fory: from 0.14.0 before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fory 1.5.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/oywndv60jwqdv6j37t7bc1qbcc4b235r
- http://www.openwall.com/lists/oss-security/2026/08/07/3
Get alerted when CVE-2026-71558 or the next vulnerability affects your stack