What’s Vulnerable › Vulnerabilities
CVE-2026-71559: Apache Fory: Uncaught panic (remote DoS) in Go meta-string decoder from untrusted metadata
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-07 · updated 2026-10-24
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in the Go implementation of Apache Fory allows an attacker to cause a denial of service by supplying crafted data containing malformed type metadata, which triggers an uncaught panic. This issue affects Apache Fory: from 0.16.0 before 1.5.0. Users of other language implementations are not affected. Users are recommended to upgrade to version 1.5.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Fory: from 0.16.0 before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fory 1.5.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/f28bw002p32yt723rvv3dcwdkljys8r3
- http://www.openwall.com/lists/oss-security/2026/08/07/4
Get alerted when CVE-2026-71559 or the next vulnerability affects your stack