What’s Vulnerable › Vulnerabilities
CVE-2026-71957: D-Link DWR-M961 Buffer Overflow via app.cgi
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-08 · updated 2026-10-24
- Weakness: CWE-120
Description
D-Link DWR-M961 devices with hardware version C1 and software version 1.1.2_C1_202602110044 contain a buffer overflow vulnerability in the app.cgi interface. A remote attacker can write an overly long string to the netAcc.addlist[].name field and execute arbitrary commands by crafting a specific payload, or cause the device to crash.
Affected products
- D-Link Corporation DWR-M961: before 1.1.5_C1_202607071108 — fixed in 1.1.5_C1_202607071108
How to fix
Upgrade to a fixed version: D-Link Corporation DWR-M961 1.1.5_C1_202607071108. Check the vendor advisory for mitigations.
References
- https://supportannouncement.us.dlink.com/security/publication.aspx?name=SAP10512
- https://www.dlink.com/middle-east/en/products/dwr-m961-4g-ac1200-lte-router
- https://www.vulncheck.com/advisories/d-link-dwr-m961-buffer-overflow-via-app-cgi
Get alerted when CVE-2026-71957 or the next vulnerability affects your stack