What’s Vulnerable › Vulnerabilities
CVE-2026-72052: net: ip6_gre: require CAP_NET_ADMIN in the device netns for changelink
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-15 · updated 2026-10-19
- Weakness: CWE-862
Description
In the Linux kernel, the following vulnerability has been resolved: net: ip6_gre: require CAP_NET_ADMIN in the device netns for changelink ip6gre_changelink() and ip6erspan_changelink() operate on at most two netns, dev_net(dev) and the tunnel link netns t->net. They differ once the device is created in or moved to a netns other than the one the request runs in. The rtnl changelink path checks CAP_NET_ADMIN only against dev_net(dev), so a caller privileged there but not in t->net can rewrite a tunnel that lives in t->net. Gate both ops on rtnl_dev_link_net_capable() at their top, before any attribute is parsed.
Affected products
- Linux kernel: from 4.19.100 before 4.20; from 5.4.16 before 5.5; 5.5 — fixed in 4.20, 5.5, 7.2
How to fix
Upgrade to a fixed version: Linux kernel 4.20, 5.5, 7.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/03d8843b143ebbbfaf48511922abc6e886575a61
- https://git.kernel.org/stable/c/0caa9f348f8b5356900de77b0bb89a697c4aff20
- https://git.kernel.org/stable/c/129f8939e5af683cec3a1a5edcb40a64636ad81e
- https://git.kernel.org/stable/c/1d4d8ee002083ca4ead5353662bf8362428af57f
- https://git.kernel.org/stable/c/220162c9fedbe992da70d70f50a10da4f45f914c
- https://git.kernel.org/stable/c/c38c8b0db3c65b597e7ece317b6cb59de3d15e69
- https://git.kernel.org/stable/c/e3724dedf57761c6de52f4d604ec74f66fd61611
- https://git.kernel.org/stable/c/f00a50876d2818bd6dc86fa98b3ef360884c53c8
Get alerted when CVE-2026-72052 or the next vulnerability affects your stack