What’s Vulnerable › Vulnerabilities

CVE-2026-7210: The expat and elementtree parsers use insufficient entropy for XML hash-flooding protection

Description

`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.

Affected products

How to fix

Upgrade to a fixed version: Python 3.13.14, 3.14.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7210 or the next vulnerability affects your stack