What’s Vulnerable › Vulnerabilities

CVE-2026-7250: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 12.10 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an unauthenticated user to cause denial of service due to improper input validation in the API request parsing middleware.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.8, 18.11.5, 19.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7250 or the next vulnerability affects your stack