What’s Vulnerable › Vulnerabilities
CVE-2026-72522
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-24
- Weakness: CWE-125
Description
libexpat before 2.8.3 has an out-of-bounds read and resultant infinite loop because low surrogates are treated the same as high surrogates during Unicode processing in the *_toUtf16 functions.
Affected products
- libexpat project libexpat: before 2.8.3 — fixed in 2.8.3
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.8.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=2053153
- https://github.com/libexpat/libexpat/pull/1296
- http://www.openwall.com/lists/oss-security/2026/08/11/5
Get alerted when CVE-2026-72522 or the next vulnerability affects your stack