What’s Vulnerable › Vulnerabilities

CVE-2026-7258: Out-of-bounds read in urldecode() on NetBSD

Description

In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, some functions, including urldecode(), pass signed char to ctype functions (like isxdigit()). On the systems with default signed char and optimized table-lookup ctype functions - such as NetBSD - this can lead to accessing array with negative offset, which can trigger a denial of service.

Affected products

How to fix

Upgrade to a fixed version: PHP 8.2.21, 8.3.31, 8.4.21, 8.5.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7258 or the next vulnerability affects your stack