What’s Vulnerable › Vulnerabilities

CVE-2026-7261: SoapServer session-persisted object use-after-free via SOAP header fault

Description

In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, when SoapServer is configured with SOAP_PERSISTENCE_SESSION, the handler object is persisted across requests via session storage. However, in the case SOAP requests results in an error, the persistance is handled incorrectly, resulting in freeing the object while keeping a pointer to it, which may lead to use-after-free. This may lead to memory corruption, information disclosure, or process crashes, with confidentiality, integrity, and availability impact on the vulnerable system.

Affected products

How to fix

Upgrade to a fixed version: PHP 8.2.31, 8.3.31, 8.4.21, 8.5.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7261 or the next vulnerability affects your stack