What’s Vulnerable › Vulnerabilities
CVE-2026-72630: Incorrect Authorization in Kibana Fleet Leading to Privilege Escalation
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-02
- Weakness: CWE-863
Description
Incorrect Authorization (CWE-863) in Kibana Fleet can lead to privilege escalation via Privilege Abuse (CAPEC-122). Fleet restricts some callers to managing integration policies for one specific integration. When an existing integration policy was updated, that restriction was evaluated against the integration recorded on the stored policy rather than against the replacement integration supplied with the update. An authenticated user holding only the Elastic Defend endpoint policy management privilege was therefore able to convert an endpoint policy they administer into a policy for a different integration, and to supply that integration's configuration at the same time.
Affected products
- Kibana: from 8.19.0 before 8.19.20; from 9.0.0 before 9.4.5; 9.5.0 — fixed in 8.19.20, 9.4.5
How to fix
Upgrade to a fixed version: Kibana 8.19.20, 9.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-72630 or the next vulnerability affects your stack