What’s Vulnerable › Vulnerabilities
CVE-2026-72638: Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-01
- Weakness: CWE-674
Description
Uncontrolled Recursion (CWE-674) in Elasticsearch can lead to denial of service via Input Data Manipulation (CAPEC-153). An authenticated user holding only low-privileged index creation permissions can submit a single request containing a specially crafted, malformed custom analysis definition that is resolved recursively without a cycle or depth check, exhausting the thread stack and terminating the affected node.
Affected products
- Elasticsearch: from 8.0.0 before 8.19.20; from 9.0.0 before 9.4.5 — fixed in 8.19.20, 9.4.5
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.20, 9.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-72638 or the next vulnerability affects your stack