What’s Vulnerable › Vulnerabilities
CVE-2026-72679: Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-01
- Weakness: CWE-674
Description
Elasticsearch does not apply its configurable input length restriction to a user-supplied pattern accepted by an intervals query. Compiling a deeply nested pattern drives unbounded recursion that exhausts the thread stack and raises a fatal error, terminating the Elasticsearch node process and causing a denial of service for that node. An authenticated user holding only read-only privileges on a single searchable index can trigger the condition with one small search request.
Affected products
- Elasticsearch: from 8.19.0 before 8.19.20; from 9.0.0 before 9.4.5 — fixed in 8.19.20, 9.4.5
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.20, 9.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-72679 or the next vulnerability affects your stack