What’s Vulnerable › Vulnerabilities
CVE-2026-72685: Inefficient Algorithmic Complexity in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-01
- Weakness: CWE-407
Description
A flaw in Elasticsearch allows a low-privileged authenticated user who can index documents to submit a single small document containing a crafted user-supplied input. Processing one such document occupies a worker thread from a bounded pool for a disproportionate amount of time, degrading the availability of indexing operations on the affected node.
Affected products
- Elasticsearch: from 8.0.0 before 8.19.20; from 9.0.0 before 9.4.5 — fixed in 8.19.20, 9.4.5
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.20, 9.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-72685 or the next vulnerability affects your stack