What’s Vulnerable › Vulnerabilities
CVE-2026-72686: Uncontrolled Recursion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-01
- Weakness: CWE-674
Description
A flaw in Elasticsearch allows a low-privileged authenticated user to submit a single request containing a crafted user-supplied input. A specific internal component validates the input using a recursive routine and applies no bound to the length of the value being validated, so the validation causes the thread to exhaust its stack. The resulting fatal error is not handled by the surrounding execution paths and terminates the affected node process, producing a denial of service.
Affected products
- Elasticsearch: from 8.0.0 before 8.19.20; from 9.0.0 before 9.4.5; from 9.5.0 before 9.5.1 — fixed in 8.19.20, 9.4.5, 9.5.1
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.20, 9.4.5, 9.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-72686 or the next vulnerability affects your stack