What’s Vulnerable › Vulnerabilities
CVE-2026-72699: Grav Login Plugin before 3.9.1 Email Enumeration via Registration
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-10-12
- Weakness: CWE-203
Description
The Grav Login plugin (getgrav/grav-plugin-login) before 3.9.1 is vulnerable to email address enumeration. The register() method in classes/Login.php throws a distinct exception (EMAIL_NOT_AVAILABLE) when a submitted email address already belongs to an existing account, while allowing registration to proceed otherwise. Because the registration endpoint has no rate limiting, an attacker can enumerate which email addresses have accounts on the site, one guess per request.
Affected products
- getgrav grav-plugin-login: before 3.9.1 — fixed in 3.9.1
How to fix
Upgrade to a fixed version: getgrav grav-plugin-login 3.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-crh8-xm27-j9g9
- https://www.vulncheck.com/advisories/grav-login-plugin-before-email-enumeration-via-registration
- https://github.com/getgrav/grav/security/advisories/GHSA-crh8-xm27-j9g9
Get alerted when CVE-2026-72699 or the next vulnerability affects your stack