What’s Vulnerable › Vulnerabilities
CVE-2026-72710: SPIP < 4.4.18 RCE via editer_objet.php Job Queue Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-15
- Weakness: CWE-915
Description
SPIP before 4.4.18 contains a mass assignment vulnerability in the editer_objet action that allows unauthenticated attackers to write arbitrary rows to any SQL table lacking a champs_editables allowlist by supplying an attacker-controlled arg parameter resolving to internal database tables. Attackers can insert a malicious row into the spip_jobs queue with a controlled PHP function and arguments, which is then dynamically executed when the cron processes the queue, resulting in remote code execution.
Affected products
- SPIP: before 4.4.18 — fixed in 4.4.18
How to fix
Upgrade to a fixed version: SPIP 4.4.18. Check the vendor advisory for mitigations.
References
- https://blog.lexfo.fr/casse-spip-sqli-to-rce.html
- https://blog.spip.net/Mise-a-jour-critique-de-securite-sortie-de-SPIP-4-4-18.html
- https://www.vulncheck.com/advisories/spip-remote-code-execution-via-editer-objet-php-job-queue-injection
Get alerted when CVE-2026-72710 or the next vulnerability affects your stack