What’s Vulnerable › Vulnerabilities
CVE-2026-72725: Discourse: Stored XSS in staff action logs injects staff UI
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-09-08
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Prior to 2026.1.6, the staff action log model rendered unescaped previous and new value fields that could inject stored cross-site scripting into the staff interface. The issue is fixed in 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.
Affected products
- discourse: before 2026.1.6; from 2026.5.0, < 2026.5.2; from 2026.6.0, < 2026.6.1
References
- https://github.com/discourse/discourse/commit/66601a6e6eeeabfcb06d2f692d68534be12de082
- https://github.com/discourse/discourse/commit/74ae22d85f4e13c7c7f2e3c13fce023feec7e033
- https://github.com/discourse/discourse/commit/fd44510b4303e7f8f0b42bd070a2d42d3cda259f
- https://github.com/discourse/discourse/security/advisories/GHSA-8x29-vv56-wj6v
Get alerted when CVE-2026-72725 or the next vulnerability affects your stack