What’s Vulnerable › Vulnerabilities
CVE-2026-72727: Discourse: Stored XSS in the moderation review queue
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-09-08
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Prior to 026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, a low-privileged user could place crafted content in the moderation review queue that executed stored cross-site scripting when a moderator viewed it on a site with a modified or disabled default Content Security Policy. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.
Affected products
- discourse: before 2026.1.6; from 2026.5.0-latest, < 2026.5.2; from 2026.6.0-latest, < 2026.6.1
References
Get alerted when CVE-2026-72727 or the next vulnerability affects your stack