What’s Vulnerable › Vulnerabilities
CVE-2026-72728: Discourse: Onebox iframe origin allowlist enforces URL authority boundary
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-09-08
- Weakness: CWE-20
Description
Discourse is an open-source discussion platform. Prior to 2026.1.7, an authenticated user could submit specially formed URLs that bypassed the Onebox allowlist and embedded malicious content in a site. This issue is fixed in versions 2026.1.7, 2026.6.2, 2026.7.1, and 2026.8.0-latest.1.
Affected products
- discourse: before 2026.1.7; from 2026.6.0-latest, < 2026.6.2; from 2026.7.0-latest, < 2026.7.1; from 2026.8.0-latest, < 2026.8.0-latest.1
References
- https://github.com/discourse/discourse/commit/92eec47e8b477cb8b4ccdb237e26dc1ba8f8b76b
- https://github.com/discourse/discourse/security/advisories/GHSA-qp9j-3v7r-wrvr
Get alerted when CVE-2026-72728 or the next vulnerability affects your stack