What’s Vulnerable › Vulnerabilities
CVE-2026-72729: Discourse: Stored XSS in discourse-local-dates plugin
- Severity: low (CVSS 2.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-09-08
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Prior to 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0, the discourse-local-dates plugin rendered crafted local-date format data as HTML on sites with a modified or disabled default Content Security Policy. This issue is fixed in versions 2026.1.6, 2026.5.2, 2026.6.1, and 2026.7.0.
Affected products
- discourse: before 2026.1.6; from 2026.5.0-latest, < 2026.5.2; from 2026.6.0-latest, < 2026.6.1
References
- https://github.com/discourse/discourse/commit/9768f476ed86ea202440cd2b6245af8a4f94ec69
- https://github.com/discourse/discourse/commit/981ba23d33d2e2d98f6690734116af58f2cea938
- https://github.com/discourse/discourse/commit/a7e509bfa1aa6288b447503de6ef798c31a62751
- https://github.com/discourse/discourse/commit/d5d5055fbdf04d5bd72fcaa7e4257fac5adac049
- https://github.com/discourse/discourse/security/advisories/GHSA-rw96-2xg7-h54g
Get alerted when CVE-2026-72729 or the next vulnerability affects your stack