What’s Vulnerable › Vulnerabilities
CVE-2026-7273: Zyxel GS1900 Series Switches Stack-Based Buffer Overflow Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-09-21
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-16 · updated 2026-10-25
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability in the CGI program of Zyxel GS1900-48HPv2 firmware versions through 2.90(ABTQ.1)C0 could allow a LAN-based, unauthenticated attacker to exploit the flaw and potentially execute OS commands via a crafted HTTP request.
Affected products
- Zyxel GS1900-10HP firmware: before 2.90\(aazi.2\)c0 — fixed in 2.90\(aazi.2\)c0
- Zyxel GS1900-16 firmware: before 2.90\(aahj.2\)c0 — fixed in 2.90\(aahj.2\)c0
- Zyxel GS1900-24 firmware: before 2.90\(aahl.2\)c0 — fixed in 2.90\(aahl.2\)c0
- Zyxel GS1900-24E firmware: before 2.90\(aahk.2\)c0 — fixed in 2.90\(aahk.2\)c0
- Zyxel GS1900-24EP firmware: before 2.90\(abto.2\)c0 — fixed in 2.90\(abto.2\)c0
- Zyxel GS1900-24HPv2 firmware: before 2.90\(abtp.2\)c0 — fixed in 2.90\(abtp.2\)c0
- Zyxel GS1900-48 firmware: before 2.90\(aahn.2\)c0 — fixed in 2.90\(aahn.2\)c0
- Zyxel GS1900-48HPv2 firmware: before 2.90\(abtq.2\)c0 — fixed in 2.90\(abtq.2\)c0
- Zyxel GS1900-8 firmware: before 2.90\(aahh.2\)c0 — fixed in 2.90\(aahh.2\)c0
- Zyxel GS1900-8HP firmware: before 2.90\(aahi.2\)c0 — fixed in 2.90\(aahi.2\)c0
How to fix
Upgrade to a fixed version: Zyxel GS1900-10HP firmware 2.90\(aazi.2\)c0; Zyxel GS1900-16 firmware 2.90\(aahj.2\)c0; Zyxel GS1900-24 firmware 2.90\(aahl.2\)c0; Zyxel GS1900-24E firmware 2.90\(aahk.2\)c0; Zyxel GS1900-24EP firmware 2.90\(abto.2\)c0; Zyxel GS1900-24HPv2 firmware 2.90\(abtp.2\)c0; Zyxel GS1900-48 firmware 2.90\(aahn.2\)c0; Zyxel GS1900-48HPv2 firmware 2.90\(abtq.2\)c0; Zyxel GS1900-8 firmware 2.90\(aahh.2\)c0; Zyxel GS1900-8HP firmware 2.90\(aahi.2\)c0. Check the vendor advisory for mitigations.
References
- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-stack-based-buffer-overflow-vulnerability-in-gs1900-series-switches-06-16-2026
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-7273
- https://www.greynoise.io/blog/open-season-on-kapibala-attacker-steals-government-records-wordpress-exploitation
Get alerted when CVE-2026-7273 or the next vulnerability affects your stack