What’s Vulnerable › Vulnerabilities

CVE-2026-72763: n8n before 1.123.67 Credential Exfiltration via Sub-Workflow

Description

n8n before 1.123.67, 2.31.5, and 2.32.1 validates credential-access only for a node's top-level credentials and not for credentials referenced inside an Execute Sub-workflow node's inline workflow JSON. A member with Editor access to a shared workflow (when workflow sharing is enabled) who knows a target credential's ID can reference that credential in the inline JSON; it passes save-time and runtime validation and resolves in the parent workflow's project context, allowing the attacker to use or exfiltrate credentials they are not permitted to access.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.67, 2.31.5; n8n-io n8n 1.123.67. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-72763 or the next vulnerability affects your stack