What’s Vulnerable › Vulnerabilities
CVE-2026-72767: n8n before 1.123.67 Remote Code Execution via Git node
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-29
- Weakness: CWE-78
Description
n8n before 1.123.67, 2.x before 2.31.5, and 2.32.x before 2.32.1 contain a remote code execution vulnerability in the Git node. Authenticated users with rights to create and execute workflows can stage a crafted local repository that causes git to run hooks under default git security settings, executing arbitrary commands as the n8n process user. Both self-hosted and cloud instances are affected.
Affected products
- n8n-io n8n: before 1.123.67; from 2.0.0 before 2.31.5; 2.32.0 (and their updates) — fixed in 1.123.67, 2.31.5
- n8n-io n8n: before 1.123.67 — fixed in 1.123.67
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.67, 2.31.5; n8n-io n8n 1.123.67. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-rcv6-pvrj-4xcg
- https://www.vulncheck.com/advisories/n8n-before-remote-code-execution-via-git-node
Get alerted when CVE-2026-72767 or the next vulnerability affects your stack