What’s Vulnerable › Vulnerabilities
CVE-2026-72771: n8n before 2.32.1 Credential Restriction Bypass via AI/LLM Nodes
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-29
- Weakness: CWE-863
Description
n8n versions before 2.32.1 fail to enforce the Allowed HTTP Request Domains allowlist in multiple AI and LLM nodes when user-supplied base or endpoint URLs are configured. Low-privileged workflow editors with use-only access to shared credentials can redirect requests to attacker-controlled hosts and exfiltrate credential secrets for reuse against underlying services.
Affected products
- n8n-io n8n: before 2.31.5; 2.32.0 (and their updates) — fixed in 2.31.5
- n8n-io n8n: from 2.32.0 before 2.32.1 — fixed in 2.32.1
How to fix
Upgrade to a fixed version: n8n-io n8n 2.31.5; n8n-io n8n 2.32.1. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-64xh-79j6-r5v8
- https://www.vulncheck.com/advisories/n8n-before-credential-restriction-bypass-via-ai-llm-nodes
Get alerted when CVE-2026-72771 or the next vulnerability affects your stack