What’s Vulnerable › Vulnerabilities
CVE-2026-72772: n8n before 2.32.1 Authentication Bypass via Token Exchange
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-29
- Weakness: CWE-640
Description
n8n before 2.32.1 (and before 2.31.5) is vulnerable to account takeover via the Token Exchange Embed Login feature. When a validly-signed incoming token was matched to a local account by its email claim, the service did not verify that the email claim was verified, nor that the trusted key's permitted role ceiling covered that account. As a result, anyone able to obtain a token accepted by a configured trusted key (for example, a trusted issuer emitting unverified email addresses) could authenticate as any existing user and gain full account control. This issue only affects instances where the embed login feature is enabled and at least one trusted key source is configured.
Affected products
- n8n-io n8n: before 2.31.5; 2.32.0 (and their updates) — fixed in 2.31.5
- n8n-io n8n: from 2.32.0 before 2.32.1 — fixed in 2.32.1
How to fix
Upgrade to a fixed version: n8n-io n8n 2.31.5; n8n-io n8n 2.32.1. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-8342-988q-86cr
- https://www.vulncheck.com/advisories/n8n-before-authentication-bypass-via-token-exchange
Get alerted when CVE-2026-72772 or the next vulnerability affects your stack