What’s Vulnerable › Vulnerabilities
CVE-2026-72775: n8n before 1.123.67 SQL Injection via PostgresTrigger Node
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-29
- Weakness: CWE-89
Description
n8n before 1.123.67, 2.31.5, and 2.32.1 contains a SQL injection vulnerability in the PostgresTrigger node, which interpolates user-supplied identifier parameters (channel, function, and trigger names) into SQL statements without proper escaping. An authenticated user can inject arbitrary SQL executed against the connected PostgreSQL database with the configured credential's privileges, allowing full read and write access.
Affected products
- n8n-io n8n: before 1.123.67; from 2.31.0 before 2.31.5; 2.32.0 (and their updates) — fixed in 1.123.67, 2.31.5
- n8n-io n8n: before 1.123.67 — fixed in 1.123.67
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.67, 2.31.5; n8n-io n8n 1.123.67. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-jqwr-vx3p-r266
- https://www.vulncheck.com/advisories/n8n-before-sql-injection-via-postgrestrigger-node
Get alerted when CVE-2026-72775 or the next vulnerability affects your stack