What’s Vulnerable › Vulnerabilities
CVE-2026-72778: Craft CMS 5.0.0-RC1 before 5.10.6 Authenticated RCE via condition.config
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-24
- Weakness: CWE-915
Description
Craft CMS versions from 4.0.0-RC1 before 4.18.2 and from 5.0.0-RC1 before 5.10.6 contain an authenticated remote code execution vulnerability in the control panel element-search condition handling. Craft cleanses the outer request-controlled condition array via Component::cleanseConfig(), but Conditions::createCondition() later decodes and merges the JSON string in condition.config without re-running cleanseConfig() on the decoded configuration. Because condition.config is a JSON string during the first cleanse, Yii special config keys such as 'as ...' and 'on ...' can be hidden inside it and, after JSON decoding, are interpreted by Yii as behavior/event configuration during FieldLayout object creation. An attacker with an authenticated control panel session (and a valid CSRF token) can exploit this to execute operating system commands as the PHP/web user.
Affected products
- craftcms cms: from 5.0.0-RC1 before 5.10.6; from 4.0.0-RC1 before 4.18.2 — fixed in 4.18.2, 5.10.6
How to fix
Upgrade to a fixed version: craftcms cms 4.18.2, 5.10.6. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-265m-7826-wjqm
- https://www.vulncheck.com/advisories/craft-cms-rc1-before-authenticated-rce-via-condition-config
Get alerted when CVE-2026-72778 or the next vulnerability affects your stack