What’s Vulnerable › Vulnerabilities
CVE-2026-72819: Grav CMS before 2.0.13 Remote Code Execution via ZIP Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-10-08
- Weakness: CWE-94
Description
Grav CMS before 2.0.13 contains a remote code execution vulnerability in the Flex Objects plugin settings validation that allows authenticated users to execute arbitrary code by uploading a ZIP file containing PHP code. Attackers can bypass routine name validation by using array notation instead of string notation, call the unZip routine with a malicious archive, and write PHP files to the web root for execution.
Affected products
- getgrav grav: before 2.0.13 — fixed in 2.0.13
How to fix
Upgrade to a fixed version: getgrav grav 2.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-r94f-hx44-8jqf
- https://www.vulncheck.com/advisories/grav-cms-before-remote-code-execution-via-zip-upload
- https://github.com/getgrav/grav/security/advisories/GHSA-r94f-hx44-8jqf
Get alerted when CVE-2026-72819 or the next vulnerability affects your stack