What’s Vulnerable › Vulnerabilities
CVE-2026-72823: Grav before 1.0.13 API-key scope cap bypass via DemoController
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-08-31
- Weakness: CWE-862
Description
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.13 contains an API-key scope cap bypass in DemoController. Its private requireSuper() method checks isSuperAdmin() and returns early before invoking requirePermission(), so the api_key_scopes cap (enforced only in requirePermission()) is skipped. As a result, any scoped API key minted on a super account can bypass its scope restrictions when calling the baseline() and reset() operations (e.g. POST /api/v1/demo/reset), allowing it to capture the demo baseline or force a demo reset. Impact is bounded to demo-engine control and is conditional on demo mode being configured with writable resources.
Affected products
- getgrav grav: before 1.0.13 — fixed in 1.0.13
How to fix
Upgrade to a fixed version: getgrav grav 1.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-vq9w-jwj5-wfjg
- https://www.vulncheck.com/advisories/grav-before-api-key-scope-cap-bypass-via-democontroller
Get alerted when CVE-2026-72823 or the next vulnerability affects your stack