What’s Vulnerable › Vulnerabilities
CVE-2026-72824: Grav before 1.0.13 API Key Scope Bypass via PagesController
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-08-31
- Weakness: CWE-862
Description
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.13 contains an API key scope-cap bypass in PagesController::guardTwigContent(). The Twig-toggle check uses a bare isSuperAdmin() gate that does not consult api_key_scopes, so a least-privilege API key scoped only to api.pages.write and minted on a super account can enable process.twig on a page save even though admin.pages_twig is intentionally outside the api.pages scope. When security.twig_content.process_enabled=true and editor_enabled=false, this allows Twig-in-content to execute server-side, resulting in server-side template injection (SSTI) and remote code execution.
Affected products
- getgrav grav: before 1.0.13 — fixed in 1.0.13
How to fix
Upgrade to a fixed version: getgrav grav 1.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-96xv-p87j-58mx
- https://www.vulncheck.com/advisories/grav-before-api-key-scope-bypass-via-pagescontroller
- https://github.com/getgrav/grav/security/advisories/GHSA-96xv-p87j-58mx
Get alerted when CVE-2026-72824 or the next vulnerability affects your stack