What’s Vulnerable › Vulnerabilities
CVE-2026-72825: Grav API Plugin before 1.0.13 API-key scope cap bypass via ReportsController
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-10-29
- Weakness: CWE-862
Description
The getgrav/grav-plugin-api plugin before 1.0.13 contains an API-key scope cap bypass in the POST /reports/twig-content/allowlist endpoint (ReportsController). The endpoint enforces requirePermission('api.config.write') followed by a bare isSuperAdmin() check instead of requireSuper(). Because isSuperAdmin() reads access.api.super directly and never consults api_key_scopes, a least-privilege API key scoped to api.config.write minted on a super account passes the gate, allowing an attacker to append attacker-chosen tokens to the security.twig_sandbox allowlist (persisted to user/config/security.yaml). Widening the allowlist turns any subsequent Twig-in-content render into an SSTI/RCE sink.
Affected products
- getgrav grav-plugin-api: before 1.0.13 — fixed in 1.0.13
How to fix
Upgrade to a fixed version: getgrav grav-plugin-api 1.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-v5ph-7v92-wqm6
- https://www.vulncheck.com/advisories/grav-before-api-key-scope-cap-bypass-via-reportscontroller
- https://github.com/getgrav/grav/security/advisories/GHSA-v5ph-7v92-wqm6
Get alerted when CVE-2026-72825 or the next vulnerability affects your stack