What’s Vulnerable › Vulnerabilities
CVE-2026-72827: Grav CMS before 2.0.13 Remote Code Execution via Twig
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-09-08
- Weakness: CWE-1336
Description
Grav CMS before 2.0.13 contains a server-side template injection vulnerability in email-action parameters that allows low-privileged page editors to execute arbitrary operating-system commands. Attackers can inject Twig payloads using the unsandboxed find filter in email subject, body, to, or from fields to achieve remote code execution when forms are submitted.
Affected products
- getgrav grav: before 2.0.13 — fixed in 2.0.13
How to fix
Upgrade to a fixed version: getgrav grav 2.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-xx48-97m4-h7qm
- https://www.vulncheck.com/advisories/grav-cms-before-remote-code-execution-via-twig
- https://github.com/getgrav/grav/security/advisories/GHSA-xx48-97m4-h7qm
Get alerted when CVE-2026-72827 or the next vulnerability affects your stack