What’s Vulnerable › Vulnerabilities
CVE-2026-72828: Grav before 1.0.13 API Key Scope Bypass via InvitationsController
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-08-31
- Weakness: CWE-269
Description
Grav Plugin API (getgrav/grav-plugin-api) before 1.0.13 fails to enforce API-key scope caps in InvitationsController. The strip-super and accept-groups decisions are gated on a bare isSuperAdmin() check rather than a scope-aware permission check, so a least-privilege API key (scoped to api.users.write) minted on a super account can create an invitation record containing super-admin access flags. When the invitation is accepted, those flags are written verbatim to the new account, resulting in privilege escalation to a fully controlled super account.
Affected products
- getgrav grav: before 1.0.13 — fixed in 1.0.13
How to fix
Upgrade to a fixed version: getgrav grav 1.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-wvpj-fg8h-843q
- https://www.vulncheck.com/advisories/grav-before-api-key-scope-bypass-via-invitationscontroller
Get alerted when CVE-2026-72828 or the next vulnerability affects your stack