What’s Vulnerable › Vulnerabilities
CVE-2026-72829: Grav before 1.0.13 API Key Scope Bypass via UsersController
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-08-31
- Weakness: CWE-269
Description
The Grav API plugin (getgrav/grav-plugin-api) before 1.0.13 contains an API-key scope-cap bypass in UsersController's create() and update() methods. These methods enforce the scope cap only for api.users.write, but gate super-privilege grants on a bare isSuperAdmin() check that reads access.api.super directly without consulting the key's scopes. As a result, an api.users.write-scoped key minted on a super account can set access.api.super or assign a super-granting group to mint or promote a full super account, then authenticate as that account for uncapped administrative privileges.
Affected products
- getgrav grav: before 1.0.13 — fixed in 1.0.13
How to fix
Upgrade to a fixed version: getgrav grav 1.0.13. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-jrm3-jpp7-3gmx
- https://www.vulncheck.com/advisories/grav-before-api-key-scope-bypass-via-userscontroller
- https://github.com/getgrav/grav/security/advisories/GHSA-jrm3-jpp7-3gmx
Get alerted when CVE-2026-72829 or the next vulnerability affects your stack