What’s Vulnerable › Vulnerabilities
CVE-2026-72833: Grav 1.0.6 through 1.0.11 Privilege Escalation via Scoped API Keys
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-09-30
- Weakness: CWE-269
Description
The Grav API plugin (getgrav/grav-plugin-api) versions >= 1.0.6 and <= 1.0.11 contain a privilege escalation vulnerability. A scoped API key minted on a super-admin account bypasses its declared scope cap on four isSuperAdmin()-gated write endpoints (in GroupsController, AccountsConfigController, PreferencesController, and DashboardWidgetController). These endpoints authorize via a super-admin early-return that never invokes requirePermission()—the sole enforcement point of the scope cap—so a 'read-only'-scoped key (e.g. api.pages.read) can perform super-only write operations, including rewriting group ACL maps to grant super-admin privileges to arbitrary accounts. A leaked or delegated read-only CI/monitoring key can therefore gain full super-admin write capability. Fixed in 1.0.13.
Affected products
- getgrav grav-plugin-api: from 1.0.6 through 1.0.11
References
- https://github.com/getgrav/grav/security/advisories/GHSA-jqgq-v53x-x99g
- https://www.vulncheck.com/advisories/grav-through-privilege-escalation-via-scoped-api-keys
Get alerted when CVE-2026-72833 or the next vulnerability affects your stack