What’s Vulnerable › Vulnerabilities
CVE-2026-72841: luci-app-openvpn Path Traversal RCE via instance_name2
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-13 · updated 2026-09-30
- Weakness: CWE-73
Description
luci-app-openvpn fails to properly validate the instance_name2 parameter during file upload, allowing authenticated users to perform path traversal and write arbitrary files outside the intended directory. Attackers can upload malicious payloads to gain persistent root code execution by placing SSH keys in system directories accessible on reboot.
Affected products
- openwrt luci: before 24.10.7; from 25.12.0 before 25.12.4 — fixed in 24.10.7, 25.12.4
How to fix
Upgrade to a fixed version: openwrt luci 24.10.7, 25.12.4. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/luci/security/advisories/GHSA-jjcx-c284-2qv8
- https://www.vulncheck.com/advisories/luci-app-openvpn-path-traversal-rce-via-instance-name2
- https://github.com/openwrt/luci/security/advisories/GHSA-jjcx-c284-2qv8
Get alerted when CVE-2026-72841 or the next vulnerability affects your stack